Its upgrade time again!

by Smartpay
in Contactless Payments, EFTPOS
25 Jul 2016  |  0 Comments


The payments industry is constantly developing new payment technology and software to help protect your business and your customers against fraud.

To ensure you have the most secure and up-to-date solution you may need to upgrade your EFTPOS terminal if you are currently running the 5.2 version software. 5.2 specification EFTPOS terminals The 5.2 specification EFTPOS terminals have been in place for about three years. Now there are newer specification EFTPOS terminals available which offer better protection against fraud. Because of this, the 5.2 specification terminals have a sunset date of 1st June 2014.

This means if you have a 5.2 specification terminal it will not work after 1st June 2014. It is important that you upgrade now to avoid interruptions to your business. 5F5289B29FCDDEEB6E9C2BAC910F4C2E Hypercom pinpad What does this mean for you? If you are a Smartpay customer your upgrade will be taken care of for you. To talk to our team about joining Smartpay call now on 0800 4 SMARTPAY (0800 476 278).